Skip to content

See how the carbon for a part is calculated

This example shows how to see how aP Pro calculates the carbon for a part by viewing the Formula Dependencies for the outputs of a sustainability analysis for the part.

Seeing how carbon is calculated can help you understand the significance of the data that you input for your scenario.

Requirements

To enter and analyze sustainability data, you must have an aPriori Sustainability License and aP Pro 2023 R1 or later.

Limitations

  • aP Pro does not yet support Sustainability analysis for all process groups. For a list of currently supported process groups, see Processes supported in Sustainability.
  • Carbon from product use, tooling, and end-of-life is not currently considered.

Prerequisites

This example requires a part that has been costed in a version of aP Pro that includes a Sustainability License.

Procedure

  1. Open the scenario for the part.
  2. Open the Part Details tab.

    Image

  3. In the Part Details tab, expand the Table View drop-down menu, and then select Select Table View > Sustainability Summary.

    Note:

    The sustainability data is also available in the All Data table view.

    Image

  4. You can review the calculations for an entire scenario (Current, Previous, or Last Saved), an entire process group, or a particular process in a process group.

    For this example, the calculations of interest are for a particular process in the Current scenario.

    To access a particular process in the current scenario, in the Cost Object column, in the Name sub-column, expand the Current node, and then the nodes for each process group until the process for which you are interested in examining a calculation is visible.

    Image

  5. Once you have found the row that contains the scenario, process group, or process that you are interested in, find the column or sub-column for the data that you are interested in examining a calculation for.

    The cell of interest is at the intersection of this sub-column and row that contain the process or process group for which you are interested in examining a calculation is visible.

    For this example, the process of interest is Waterjet Cut and the data of interest is Total Carbon, which is a sub-column in the Carbon Info column. Therefore, as this figure shows, the cell of interest is at the intersection of that row and column.

    Image

  6. Right-click the cell of interest and then select Show Formula Dependencies.

    Image

    The Formula Dependencies dialog opens. Each row in the dialog contains a Name, Value, Unit, Description, and CSL, which shows the equation for the data and links to the code for the calculation.

    Image

    For this example, the three main nodes in the Formula Dependencies dialog for the Total Carbon for the Waterjet Cut process are:

    • Logistics Carbon details. By default this will be zero. See Edit the Logistics Carbon for a part.

    • Material Carbon details. Expand the Material Carbon node and its sub-items to see more details.

    • Process Carbon details. Expand the Process Carbon node and its sub-items to see more details.

    For more information on Formula Dependencies in aP Pro, see Show Formula Dependencies.

    Tip:

    As required to see all the data in the Formula Dependencies dialog, expand the window or adjust the column widths.

    Info:

    A pencil icon, Pencil icon indicates you can edit the value, indicates that you can edit a value. For more information, see Part Details Overrides.

  7. To examine sub-calculations, expand the nodes in the Name column of the dialog.

    Formula Dependencies for a cell in the Parts Details tab

For more information on Formula Dependencies in aP Pro, see Show Formula Dependencies.